Is V5.1 of AgendaX compatible with Exchange Online / Office 365 / Exchange 2013?

No, you will need to upgrade to V6 of AgendaX, as V5.1 is not compatible with the above Exchange Server versions. You can get a quote for the Upgrade from our Sales team. Please fill out the inquiry form on our homepage and a member of our Sales team will get in touch with you asap.

Back to FAQs 0 0